Retour à l'accueil du site.


 FAQFAQ   RechercherRechercher   Liste des MembresListe des Membres   Groupes d'utilisateursGroupes d'utilisateurs S'enregistrerS'enregistrer 
ProfilProfil   Se connecter pour vérifier ses messages privésSe connecter pour vérifier ses messages privés   ConnexionConnexion 

MyFreeTV 2 !
Aller à la page 1, 2, 3, 4, 5, 6, 7  Suivante
 
Poster un nouveau sujet   Répondre au sujet    MacADSL Index du Forum -> Logiciels "box" et logiciels liés à l'ADSL
Voir le sujet précédent :: Voir le sujet suivant  
Auteur Message
®om
Membre habitué


Inscrit le: 14 Jan 2006
Messages: 41

MessagePosté le: 14-Jan-06 17:01:30    Sujet du message: MyFreeTV 2 ! Répondre en citant





Le site officiel de MyFreeTV:
http://myfreetv.sourceforge.net


Dernière édition par ®om le 26-Fév-06 13:32:30; édité 3 fois
Revenir en haut
Voir le profil de l'utilisateur Envoyer un message privé
LL
Membre hyperactif


Inscrit le: 13 Fév 2004
Messages: 1873
Localisation: Dans une lapinière

MessagePosté le: 14-Jan-06 17:34:03    Sujet du message: Répondre en citant

Pourquoi ne pas avoir posté
_________________
Revenir en haut
Voir le profil de l'utilisateur Envoyer un message privé Envoyer l'e-mail Visiter le site web du posteur Adresse AIM MSN Messenger
Anthony
Administrateur


Inscrit le: 07 Mar 2001
Messages: 7344
Localisation: Paris Nancy

MessagePosté le: 14-Jan-06 18:19:05    Sujet du message: Répondre en citant

C'est compatible Mac OS X ?

Si la réponse est non, ce sujet sera... effacé !
_________________
parrainage boursorama

Aidez MacADSL en faisant vos emplettes sur l'AppleStore !
Comparatif des offres ADSL Test d'éligibilité ADSL
Revenir en haut
Voir le profil de l'utilisateur Envoyer un message privé Visiter le site web du posteur
®om
Membre habitué


Inscrit le: 14 Jan 2006
Messages: 41

MessagePosté le: 14-Jan-06 20:39:13    Sujet du message: Répondre en citant

Anthony a écrit:
C'est compatible Mac OS X ?

Si la réponse est non, ce sujet sera... effacé !

Bah oui, y'a bien une jvm (java virtual machine) pour mac, non?
Revenir en haut
Voir le profil de l'utilisateur Envoyer un message privé
Anthony
Administrateur


Inscrit le: 07 Mar 2001
Messages: 7344
Localisation: Paris Nancy

MessagePosté le: 14-Jan-06 20:41:03    Sujet du message: Répondre en citant

Cool, j'essaie alors !

Edit : marche pas !

Code:
Exception in thread "main" java.lang.UnsupportedClassVersionError: org/rom/myfreetv/view/MyFreeTV (Unsupported major.minor version 49.0)
   at java.lang.ClassLoader.defineClass0(Native Method)
   at java.lang.ClassLoader.defineClass(ClassLoader.java:539)
   at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:123)
   at java.net.URLClassLoader.defineClass(URLClassLoader.java:251)
   at java.net.URLClassLoader.access$100(URLClassLoader.java:55)
   at java.net.URLClassLoader$1.run(URLClassLoader.java:194)
   at java.security.AccessController.doPrivileged(Native Method)
   at java.net.URLClassLoader.findClass(URLClassLoader.java:187)
   at java.lang.ClassLoader.loadClass(ClassLoader.java:289)
   at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:274)
   at java.lang.ClassLoader.loadClass(ClassLoader.java:235)
   at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:302)
Exception in thread "main" java.lang.UnsupportedClassVersionError: org/rom/myfreetv/view/MyFreeTV

_________________
parrainage boursorama

Aidez MacADSL en faisant vos emplettes sur l'AppleStore !
Comparatif des offres ADSL Test d'éligibilité ADSL
Revenir en haut
Voir le profil de l'utilisateur Envoyer un message privé Visiter le site web du posteur
®om
Membre habitué


Inscrit le: 14 Jan 2006
Messages: 41

MessagePosté le: 14-Jan-06 20:45:32    Sujet du message: Répondre en citant

Anthony a écrit:
Cool, j'essaie alors !

Edit : marche pas !

Code:
Exception in thread "main" java.lang.UnsupportedClassVersionError: org/rom/myfreetv/view/MyFreeTV (Unsupported major.minor version 49.0)
   at java.lang.ClassLoader.defineClass0(Native Method)
   at java.lang.ClassLoader.defineClass(ClassLoader.java:539)
   at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:123)
   at java.net.URLClassLoader.defineClass(URLClassLoader.java:251)
   at java.net.URLClassLoader.access$100(URLClassLoader.java:55)
   at java.net.URLClassLoader$1.run(URLClassLoader.java:194)
   at java.security.AccessController.doPrivileged(Native Method)
   at java.net.URLClassLoader.findClass(URLClassLoader.java:187)
   at java.lang.ClassLoader.loadClass(ClassLoader.java:289)
   at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:274)
   at java.lang.ClassLoader.loadClass(ClassLoader.java:235)
   at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:302)
Exception in thread "main" java.lang.UnsupportedClassVersionError: org/rom/myfreetv/view/MyFreeTV

Il faut java 1.5 installé...

Je parie qu'en faisant
Code:
java -version
ça te donne 1.4.2
Revenir en haut
Voir le profil de l'utilisateur Envoyer un message privé
Anthony
Administrateur


Inscrit le: 07 Mar 2001
Messages: 7344
Localisation: Paris Nancy

MessagePosté le: 15-Jan-06 02:19:35    Sujet du message: Répondre en citant

Code:
[anthony@Mercure:~] $java -version
java version "1.4.2_09"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.4.2_09-232)
Java HotSpot(TM) Client VM (build 1.4.2-54, mixed mode)
[anthony@Mercure:~] $


Oui

Java 1.5 doit bien exister sous Mac, mais comme j'ai une config standard, c'est à dire la même que 99% des autres utilisateurs Mac, hé bien, je te laisse conclure
_________________
parrainage boursorama

Aidez MacADSL en faisant vos emplettes sur l'AppleStore !
Comparatif des offres ADSL Test d'éligibilité ADSL
Revenir en haut
Voir le profil de l'utilisateur Envoyer un message privé Visiter le site web du posteur
jathenais
Concierge


Inscrit le: 22 Avr 2003
Messages: 15051
Localisation: trop au sud à mon goût

MessagePosté le: 15-Jan-06 02:27:43    Sujet du message: Répondre en citant

je confirme ici
_________________
3 iMac G3,iMac G5 20" 1,8, PWB17" 1,67, FB V4, Linksys WRT54G, CPL, iSight, JBL Spot, HP C4580 wifi, Canon EOS 1000D, iPhone 3GS
iSmileys, WidgetCiné-TV
Revenir en haut
Voir le profil de l'utilisateur Envoyer un message privé Envoyer l'e-mail Visiter le site web du posteur Adresse AIM MSN Messenger
LL
Membre hyperactif


Inscrit le: 13 Fév 2004
Messages: 1873
Localisation: Dans une lapinière

MessagePosté le: 15-Jan-06 02:30:47    Sujet du message: Répondre en citant

Anthony a écrit:
Java 1.5 doit bien exister sous Mac


En direct du site Apple: http://www.apple.com/support/downloads/java2se50release3.html
_________________
Revenir en haut
Voir le profil de l'utilisateur Envoyer un message privé Envoyer l'e-mail Visiter le site web du posteur Adresse AIM MSN Messenger
Bernard Rey
Membre hyperactif


Inscrit le: 11 Nov 2002
Messages: 1209
Localisation: Toulouse.cong

MessagePosté le: 15-Jan-06 12:45:43    Sujet du message: Répondre en citant

Le problème, c'est que même une fois téléchargée, installée et sélectionnée dans l'utilitaire "Java Preferences", la version 1.5 n'est toujours pas "reconnue", ça me dit toujours que la version installée est 1.4.2, même après redémarrage.

Comment la "désinstaller" cette 1.4.2 (puisqu'il est bien précisé sur le site Apple que la 1.5 ne désinstalle pas la version précédente, ce que je peux que confirmer...) ?
_________________
Bernard Rey

G4 MDD 2 x 867 & iMac G5 - Free ADSL (Freebox IV - dégroupé partiel) - D-Link DGS 1005D (réseau Gigabit !) - plus 2-3 accessoires
... et aussi (pour ceux que ça peut intéresser)
FAQ Office Macintosh
Revenir en haut
Voir le profil de l'utilisateur Envoyer un message privé
®om
Membre habitué


Inscrit le: 14 Jan 2006
Messages: 41

MessagePosté le: 15-Jan-06 12:46:31    Sujet du message: Répondre en citant

Bernard Rey a écrit:
Le problème, c'est que même une fois téléchargée, installée et sélectionnée dans l'utilitaire "Java Preferences", la version 1.5 n'est toujours pas "reconnue", ça me dit toujours que la version installée est 1.4.2, même après redémarrage.

Comment la "désinstaller" cette 1.4.2 (puisqu'il est bien précisé sur le site Apple que la 1.5 ne désinstalle pas la version précédente, ce que je peux que confirmer...) ?

Hmmm... Je ne m'y connais pas en MAC, mais il doit falloir modifier le CLASSPATH ou les alias...
Revenir en haut
Voir le profil de l'utilisateur Envoyer un message privé
LL
Membre hyperactif


Inscrit le: 13 Fév 2004
Messages: 1873
Localisation: Dans une lapinière

MessagePosté le: 15-Jan-06 12:49:35    Sujet du message: Répondre en citant

Bernard Rey a écrit:
Le problème, c'est que même une fois téléchargée, installée et sélectionnée dans l'utilitaire "Java Preferences", la version 1.5 n'est toujours pas "reconnue", ça me dit toujours que la version installée est 1.4.2, même après redémarrage.

Comment la "désinstaller" cette 1.4.2 (puisqu'il est bien précisé sur le site Apple que la 1.5 ne désinstalle pas la version précédente, ce que je peux que confirmer...) ?


C'est identique de mon côté.
_________________
Revenir en haut
Voir le profil de l'utilisateur Envoyer un message privé Envoyer l'e-mail Visiter le site web du posteur Adresse AIM MSN Messenger
Anthony
Administrateur


Inscrit le: 07 Mar 2001
Messages: 7344
Localisation: Paris Nancy

MessagePosté le: 15-Jan-06 13:06:58    Sujet du message: Répondre en citant

Je crois qu'en fait les deux version coexistent sous Mac, mais que par défaut c'est la plus vieille qui est activée. Ton application ne peut pas faire en sorte de choisir la machine Java à utiliser ?
_________________
parrainage boursorama

Aidez MacADSL en faisant vos emplettes sur l'AppleStore !
Comparatif des offres ADSL Test d'éligibilité ADSL
Revenir en haut
Voir le profil de l'utilisateur Envoyer un message privé Visiter le site web du posteur
®om
Membre habitué


Inscrit le: 14 Jan 2006
Messages: 41

MessagePosté le: 15-Jan-06 13:14:17    Sujet du message: Répondre en citant

Anthony a écrit:
Je crois qu'en fait les deux version coexistent sous Mac, mais que par défaut c'est la plus vieille qui est activée. Ton application ne peut pas faire en sorte de choisir la machine Java à utiliser ?

http://forums.macosxhints.com/showthread.php?t=47531
Revenir en haut
Voir le profil de l'utilisateur Envoyer un message privé
Bernard Rey
Membre hyperactif


Inscrit le: 11 Nov 2002
Messages: 1209
Localisation: Toulouse.cong

MessagePosté le: 15-Jan-06 16:48:43    Sujet du message: Répondre en citant

Effectivement, merci ®om, je n'avais pas vu qu'il fallait faire glisser la ligne J2SE 5.0 au-dessus de J2SE 1.4.2 dans la deuxième fenêtre du réglage de préférences (et pas seulement choisir la version par le menu déroulant).

Bon, du coup, maintenant l'application s'ouvre d'un simple double-clic (bien, ça) mais fait régulièrement un échec quand je double-clique sur le programme TV à visualiser en me disant que ça "peut provenir d'un mauvais chemin vers le logiciel VLC"....

Ah, ça y est : j'ai remplacé le chemin /usr/bin/vlc indiqué par défaut par /Applications/VLC.app/Contents/MacOS/VLC (on est loin de la simplicité du Mac pour le coup) et cette fois c'est apparemment bon !

[MàJ] ennuyeux, tout de même : lorsqu'on quitte puis redémarre, il ne mémorise pas le chemin indiqué, donc il faut recommencer à chaque fois... Espérons que quelqu'un (de plus doué que moi) sache modifier cette version pour qu'elle soit mieux adaptée à l'utilisateur de Mac "moyen".

Pour l'enregistrement aussi, il va falloir bidouiller un peu pour mettre un chemin par défaut plus "conforme" (et peut-être aussi des fenêtres de dialogue moins "windowsiennes").

Là j'en suis à tenter la programmation, et tout se bloque une fois que je clique sur le bouton "OK".

[MàJ] à la deuxième tentative, ça semble marcher...

Mais bon, on va essayer de se rôder... Merci, en tout cas, c'est au minimum prometteur
_________________
Bernard Rey

G4 MDD 2 x 867 & iMac G5 - Free ADSL (Freebox IV - dégroupé partiel) - D-Link DGS 1005D (réseau Gigabit !) - plus 2-3 accessoires
... et aussi (pour ceux que ça peut intéresser)
FAQ Office Macintosh
Revenir en haut
Voir le profil de l'utilisateur Envoyer un message privé
Montrer les messages depuis:   
Poster un nouveau sujet   Répondre au sujet    MacADSL Index du Forum -> Logiciels "box" et logiciels liés à l'ADSL Toutes les heures sont au format GMT + 2 Heures
Aller à la page 1, 2, 3, 4, 5, 6, 7  Suivante
Page 1 sur 7

 
Sauter vers:  
Vous ne pouvez pas poster de nouveaux sujets dans ce forum
Vous ne pouvez pas répondre aux sujets dans ce forum
Vous ne pouvez pas éditer vos messages dans ce forum
Vous ne pouvez pas supprimer vos messages dans ce forum
Vous ne pouvez pas voter dans les sondages de ce forum